您的位置:首页 > 其它

九度OJ 1001 A+B for Matrices

2015-01-04 00:03 337 查看
题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:14669

解决:5996

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers
in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0


样例输出:
1
5


#include<stdio.h>
#define MAX 10
int A[MAX][MAX];
int B[MAX][MAX];
int main(int argc, char *argv[])
{
    int m,n;
    scanf("%d",&m);
    while(m)
    {
        int total=0;
        scanf("%d",&n);
        int i,j;
        for(i=0;i<m;++i)
            for(j=0;j<n;++j)
            {
                scanf("%d",&A[i][j]);
            }
        for(i=0;i<m;++i)
            for(j=0;j<n;++j)
            {
                scanf("%d",&B[i][j]);
            }
 
        for(i=0;i<m;++i){
            int sum=0;
            for(j=0;j<n;++j)
            {
                sum+=A[i][j];
                sum+=B[i][j];
            }
            if(sum==0)total++;
        }
        for(i=0;i<n;++i){
            int sum=0;
            for(j=0;j<m;++j)
            {
                sum+=A[j][i];
                sum+=B[j][i];
            }
            if(sum==0)total++;
        }
        printf("%d\n",total);
        scanf("%d",&m);
    }
    return 0;
}
 
/**************************************************************
    Problem: 1001
    User: kirchhoff
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:916 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: