您的位置:首页 > 其它

HDU 5155 Harry And Magic Box( DP )

2015-01-03 22:34 369 查看

Harry And Magic Box

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 87 Accepted Submission(s): 44


[align=left]Problem Description[/align]
One day, Harry got a magical box. The box is made of n*m grids. There are sparking jewel in some grids. But the top and bottom of the box is locked by amazing magic, so Harry can’t see the inside from the top or bottom. However, four sides of the box are transparent, so Harry can see the inside from the four sides. Seeing from the left of the box, Harry finds each row is shining(it means each row has at least one jewel). And seeing from the front of the box, each column is shining(it means each column has at least one jewel). Harry wants to know how many kinds of jewel’s distribution are there in the box.And the answer may be too large, you should output the answer mod 1000000007.

[align=left]Input[/align]
There are several test cases.
For each test case,there are two integers n and m indicating the size of the box. 0≤n,m≤50.

[align=left]Output[/align]
For each test case, just output one line that contains an integer indicating the answer.

[align=left]Sample Input[/align]

1 1

2 2
2 3

[align=left]Sample Output[/align]
1
7
25

Hint

There are 7 possible arrangements for the second test case.
They are:

11 11 11 10 01 01 10
11 10 01 11 11 10 01
Assume that a grids is '1' when it contains a jewel otherwise not.

设dp[i][j] 表示前i行已经选了j列的数目。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <algorithm>
using namespace std;
#define root 1,n,1
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1
typedef long long LL;
typedef pair<int,int>pii;
#define X first
#define Y second
const int oo = 1e9+7;
const double PI = acos(-1.0);
const double eps = 1e-6 ;
const int N = 105 ;
const int mod = 1e9+7;

LL dp

, f
, C

;
int n , m ;
void init() {
f[0] = 1 ;
for( int i = 1 ; i <= 50 ; ++i ) f[i] = f[i-1] * 2 ;
for( int i = 0 ; i < N; ++i ){
C[i][0] = C[i][i] = 1 ;
for( int j = 1 ; j < i ; ++j ){
C[i][j] = ( C[i-1][j] + C[i-1][j-1] ) % mod ;
}
}
}

void Run() {
memset( dp , 0 , sizeof dp );
dp[0][0] = 1 ;
for( int i = 0 ; i < n ; ++i ){
for( int j = 0 ; j <= m ; ++j ){
for( int k = 0 ; j + k <= m ; k++ ){
LL cnt = f[j]; if( !k ) cnt--; cnt %= mod ;
dp[i+1][j+k] += ( dp[i][j] * cnt % mod * C[m-j][k] ) % mod;
dp[i+1][j+k] %= mod ;
}
}
}
printf("%I64d\n",dp
[m]);
}
int main()
{
#ifdef LOCAL
freopen("in.txt","r",stdin);
#endif // LOCAL
init();
while( ~scanf("%d%d",&n,&m) ) Run();
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: