您的位置:首页 > 其它

PKU 2084 Game of Connections

2015-01-03 15:12 295 查看
Game of Connections

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 7567Accepted: 3832
Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every
number must be connected to exactly one another.

And, no two segments are allowed to intersect.

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?
Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1.

You may assume that 1 <= n <= 100.
Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.
Sample Input
2
3
-1

Sample Output
2
5
我滴个乖乖,《算法竞赛入门经典》给的公式是错误的!!!我算了好久



,但是找到了卡特兰数的模板。高精度不会,还是先学会这种吧。
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
using namespace std;
int a[105][1050],b[1000];
void catalan() //求卡特兰数
{
int i, j, len, carry, temp;
a[1][0] = b[1] = 1;
len = 1;
for(i = 2; i <= 100; i++)
{
for(j = 0; j < len; j++) //乘法
a[i][j] = a[i-1][j]*(4*(i-1)+2);
carry = 0;
for(j = 0; j < len; j++) //处理相乘结果
{
temp = a[i][j] + carry;
a[i][j] = temp % 10;
carry = temp / 10;
}
while(carry) //进位处理
{
a[i][len++] = carry % 10;
carry /= 10;
}
carry = 0;
for(j = len-1; j >= 0; j--) //除法
{
temp = carry*10 + a[i][j];
a[i][j] = temp/(i+1);
carry = temp%(i+1);
}
while(!a[i][len-1]) //高位零处理
len --;
b[i] = len;
}
}
int main(void)
{
memset(a,0,sizeof(a));
catalan();
int n;
while(cin>>n&&n!=-1)
{

//    for( j=999;j>=0;j--) if(a
[j]) break;
for(int i=b
-1;i>=0;i--) cout<<a
[i];
cout<<endl;

// cout<<a
<<endl;
}

return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: