您的位置:首页 > 大数据 > 人工智能

Drainage Ditches - HDU 1532 最大流

2015-01-03 14:47 204 查看


Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10124    Accepted Submission(s): 4819


Problem Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection
1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to
Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

 

Sample Output

50

 

题意:最大流模板题,问从1到m的最大流。

思路:具体看大神的博客详解吧http://blog.csdn.net/y990041769/article/details/21026445

我把其中的vector改成了链表形式存边,习惯……

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int v,c,rev,next;
}Edge[410];
int n,m,h[210],tot,INF=1e9;
bool vis[210];
void AddEdge(int u,int v,int c,int rev)
{
Edge[++tot].v=v;
Edge[tot].c=c;
Edge[tot].rev=rev;
Edge[tot].next=h[u];
h[u]=tot;
}
int dfs(int s,int t,int f)
{
int i,j,k,u,v,c,rev,p,d;
if(s==t)
return f;
vis[s]=1;
for(p=h[s];p;p=Edge[p].next)
{
v=Edge[p].v;
c=Edge[p].c;
rev=Edge[p].rev;
if(!vis[v] && c>0)
{
d=dfs(v,t,min(f,c));
if(d>0)
{
Edge[p].c-=d;
Edge[rev].c+=d;
return d;
}
}
}
return 0;
}
int max_flow(int s,int t)
{
int flow=0,f;
while(true)
{
memset(vis,0,sizeof(vis));
f=dfs(s,t,INF);
if(f==0)
return flow;
flow+=f;
}
}
int main()
{
int i,j,k,u,v,c,ans;
while(~scanf("%d%d",&m,&n))
{
memset(h,0,sizeof(h));
tot=0;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&u,&v,&c);
AddEdge(u,v,c,tot+2);
AddEdge(v,u,0,tot);
}
ans=max_flow(1,n);
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: