您的位置:首页 > 其它

hdu1710 Binary Tree Traversals

2015-01-03 13:06 405 查看

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3714 Accepted Submission(s): 1654



[align=left]Problem Description[/align]
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can
be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.



[align=left]Input[/align]
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and
inorder sequence. You can assume they are always correspond to a exclusive binary tree.

[align=left]Output[/align]
For each test case print a single line specifying the corresponding postorder sequence.

[align=left]Sample Input[/align]

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6


[align=left]Sample Output[/align]

7 4 2 8 9 5 6 3 1


题目大意,已知二叉树的前序遍历和中序遍历,求它的后序遍历,我们可以通过前序遍历知道第一个点就是它的根结点,然后再看中序遍历,找出根结点在中序遍历中的位置,然后在这个位置的左边为左子树,右边为右子树。然后左子树和右子树再用上面的方法递归,即可求出它的后序遍历。下面为本题的代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int maxn = 1001;
int a[maxn];
int b[maxn];
int m;
int flag;
void CreateTree(int preLeft,int preRight,int inLeft,int inRight)
{
int i,lsize,rsize;
if(preLeft <= preRight && inLeft <= inRight)
{
for(i=inLeft; i<inRight; i++)
{
if(a[preLeft] == b[i])
{
break;
}
}
lsize = i - inLeft; // 左子树的个数
rsize = inRight - i; //右子树的个数
if(lsize > 0)
{
CreateTree(preLeft+1,preLeft + lsize,inLeft,i-1);
}
if(rsize > 0)
{
CreateTree(preLeft+lsize+1,preRight,i+1,inRight);
}
if(flag)
{
cout<<a[preLeft];
flag = 0;
}
else
{
cout<<" "<<a[preLeft];
}
}
}
int main()
{
int i;
//freopen("111","r",stdin);
while(cin>>m)
{
flag = 1;
for(i=0; i<m; i++)
{
cin>>a[i];
}
for(i=0; i<m; i++)
{
cin>>b[i];
}
CreateTree(0,m-1,0,m-1);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: