您的位置:首页 > 其它

POJ - 3984 迷宫问题(自己待ac)

2015-01-02 00:36 316 查看
迷宫问题

Time Limit: 1000MSMemory Limit: 65536KB64bit IO Format: %I64d & %I64u
Submit Status

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0


Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


Source

ac代码:(复制的)

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
using namespace std;
int a[101][101];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
struct node{
int x,y,pre;
}q[101];
void print(int i){
if(q[i].pre!=-1){
print(q[i].pre);
cout<<"("<<q[i].x<<","<<" "<<q[i].y<<")"<<endl;
}
}
void bfs(int x1,int y1){
int front=0,rear=1,m,n;
q[front].x=x1;
q[front].y=y1;
q[front].pre=-1;
while(front<rear){
for(int i=0;i<4;i++){
m=q[front].x+dx[i];
n=q[front].y+dy[i];
if(m<0||n<0||m>4||n>4||a[m][n])
continue;
else{
a[m][n]=1;
q[rear].x=m;
q[rear].y=n;
q[rear].pre=front;
rear++;
}
if(m==4&&n==4) print(front);
}
front++;
}
}
int main(){
int i,j,k,m,n;
memset(a,0,sizeof(a));
for(i=0;i<5;i++)
for(j=0;j<5;j++)
cin>>a[i][j];
cout<<"(0, 0)"<<endl;
bfs(0,0);
cout<<"(4, 4)"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: