您的位置:首页 > 其它

uva 10110 Light, more light (数论)

2015-01-01 10:57 369 查看

uva 10110 Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption
(or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any
switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?



The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output " yes" if the light is on otherwise " no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no


题目大意:有一串灯,编号从1到n全都是关闭的,你每次走过这串灯时,把可以整除次数i的编号的灯取相反状态,问n次后n号灯的状态。

解题思路:判断n因数的奇偶性。

#include<stdio.h>
#include<math.h>
int main() {
	long long n;
	while (scanf("%lld", &n) == 1, n) {
		long long t;
		t = floor(sqrt(n));
		if (t * t == n) {
			printf("yes\n");
		}
		else {
			printf("no\n");
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: