您的位置:首页 > 其它

hdu 1253 胜利大逃亡(三维bfs)

2014-12-30 22:35 417 查看
Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.



Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0


Sample Output

11


3维bfs

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
bool map[55][55][55];
int x[7] = {1,-1,0,0,0,0};
int y[7] = {0,0,1,-1,0,0};
int z[7] = {0,0,0,0,1,-1};
int  A,B,C,T;
bool vis[55][55][55];
struct node
{
int x,y,z;
int step;
bool operator<(const node &t)const
{
return t.step<step;
}
}s;
bool check(int i,int j,int k)
{
if(i>=0 && i<A && j>=0 && j<B && k>=0 && k<C && map[i][j][k]==0 && !vis[i][j][k])
{
return true;
}
return false;
}
int bfs()
{
priority_queue<node>q;
q.push(s);
node t,temp;
vis[s.x][s.y][s.z]=1;
while (!q.empty())
{
t=q.top();
q.pop();
if(t.step>T)
{
return -1;
}
if(t.x==A-1 && t.y==B-1 && t.z==C-1 && t.step<=T)
{
return t.step;
}
for (int i=0; i<6; i++)
{
temp=t;
temp.x+=x[i];
temp.y+=y[i];
temp.z+=z[i];
if(abs(temp.x-A+1)+abs(temp.y-B+1)+abs(temp.z-C+1)>T)
{
continue;
}
if (check(temp.x, temp.y, temp.z))
{
temp.step++;
q.push(temp);
vis[temp.x][temp.y][temp.z]=1;
}
}
}
return  -1;
}
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
memset(vis, false, sizeof(vis));
scanf("%d%d%d%d",&A,&B,&C,&T);
for (int i=0; i<A; i++)
{
for (int j=0; j<B; j++)
{
for (int k=0; k<C; k++)
{
int x;
scanf("%d",&x);
if(x==1)
{
map[i][j][k]=1;
}
else
{
map[i][j][k]=0;
}
}
}
}
s.x=0;
s.y=0;
s.z=0;
s.step=0;
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: