您的位置:首页 > 其它

poj 3661 Running(dp)

2014-12-30 19:27 447 查看
题目链接

Running

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5279Accepted: 1966
Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly
N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute
i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed
M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.

 

Sample Input
5 2
5
3
4
2
10

Sample Output
9


题意:跑步,有n分钟可以跑,第i分钟跑的距离为Di。每一分钟可以选择跑与不跑。跑的话疲劳程度+1,疲劳程度初始时为0,不能超过m。不跑的话每分钟疲劳-1,但是要直到疲劳程度减少为0,才可以再跑。n分钟跑完后,疲劳程度必须为0。问最多能跑多少距离?

题解:动态规划问题。用dp[i][j][0,1] 表示第i分钟,疲劳程度为j,0,1表示这分钟跑与没跑,该状态下跑的最远距离。

详情见代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define nn 11000
#define inff 0x3fffffff
using namespace std;
int n,m;
int d[nn];
int dp[nn][510][2];
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d",&d[i]);
}
for(i=0;i<=n;i++)
{
for(j=0;j<=m;j++)
dp[i][j][0]=dp[i][j][1]=-inff;
}
dp[0][0][1]=0;
for(i=0;i<n;i++)
{
for(j=0;j<=m;j++)
{
if(dp[i][j][1]>=0)
{
if(j+1==m)
dp[i+1][m][0]=max(dp[i+1][m][0],dp[i][j][1]+d[i+1]);
else
dp[i+1][j+1][1]=max(dp[i+1][j+1][1],dp[i][j][1]+d[i+1]);
if(j>1)
dp[i+1][j-1][0]=max(dp[i+1][j-1][0],dp[i][j][1]);
else
dp[i+1][0][1]=max(dp[i+1][0][1],dp[i][j][1]);
}
if(dp[i][j][0]>=0)
{
if(j>1)
dp[i+1][j-1][0]=max(dp[i+1][j-1][0],dp[i][j][0]);
else
dp[i+1][0][1]=max(dp[i+1][0][1],dp[i][j][0]);
}
}
}
printf("%d\n",dp
[0][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: