您的位置:首页 > 其它

HDOJ 题目1595 find the longest of the shortest(枚举,最短路记录路径)

2014-12-29 21:02 357 查看


find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2020    Accepted Submission(s): 708


[align=left]Problem Description[/align]
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes
to come from one city to another.

Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.

Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write
a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

[align=left]Input[/align]
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from
1 to N, Mirko is located in city 1, and Marica in city N.

In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

[align=left]Output[/align]
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

[align=left]Sample Input[/align]

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

 

[align=left]Sample Output[/align]

11
13
27

 

[align=left]Author[/align]
ailyanlu
 

[align=left]Source[/align]
HDU 2007-Spring
Programming Contest - Warm Up (1)
 记录路径这么写迪杰斯特拉可行
ac代码

#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
int n,m,x,y,map[1010][1010],v[1010],pre[1010],dis[1010];
void init(int n)
{
int i,j;
for(i=0;i<=n;i++)
{
for(j=0;j<=n;j++)
map[i][j]=INF;
map[i][i]=0;
}
}
void disj(int s,int flag)
{
int i,j,min,k;
memset(v,0,sizeof(v));
for(i=1;i<=n;i++)
dis[i]=INF;
v[s]=1;
dis[s]=0;
for(i=1;i<=n;i++)
{
min=INF;
k=s;
for(j=1;j<=n;j++)
{
if(dis[j]<min&&!v[j])
{
k=j;
min=dis[j];
}
}
if(flag)
printf("%d\n",k);
v[k]=1;
for(j=1;j<=n;j++)
{
if(dis[j]>dis[k]+map[k][j])
{
dis[j]=dis[k]+map[k][j];
if(flag)
pre[j]=k;
}
}
}
}
int main()
{
//int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,ans,max=0;
init(n);
for(i=0;i<m;i++)
{
int w;
scanf("%d%d%d",&x,&y,&w);
if(w<map[x][y])
{
map[x][y]=map[y][x]=w;
}
}
memset(pre,0,sizeof(pre));
disj(1,1);
max=dis
;
for(i=n;i!=1;i=pre[i])
{
int temp=map[i][pre[i]];
map[i][pre[i]]=map[pre[i]][i]=INF;
disj(1,0);
if(max<dis
)
max=dis
;
map[i][pre[i]]=map[pre[i]][i]=temp;
}
printf("%d\n",max);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐