您的位置:首页 > 其它

HDOJ 1724 Ellipse 自适应Simpson

2014-12-27 22:57 239 查看
 自适应Simpson


Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1268    Accepted Submission(s): 493


Problem Description

Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..

Look this sample picture:



A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task
is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

 

Input

Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation 

,
A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

 

Output

For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

 

Sample Input

2
2 1 -2 2
2 1 0 2

 

Sample Output

6.283
3.142

 

Author

威士忌

 

Source

HZIEE 2007 Programming Contest

 

/* ***********************************************
Author :CKboss
Created Time :2014年12月27日 星期六 22时46分38秒
File Name :HDOJ1724.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

double a,b,l,r;

double F(double x)
{
return b*sqrt((1-x/a)*(1+x/a));
}

/// 3-points simpson

double simpson(double a,double b)
{
double c=(a+b)/2;
return (F(a)+4*F(c)+F(b))*(b-a)/6.;
}

double asr(double a,double b,double eps,double A)
{
double c=(a+b)/2;
double L=simpson(a,c),R=simpson(c,b);
if(fabs(L+R-A)<=15*eps) return L+R+(L+R-A)/15.0;
return asr(a,c,eps/2,L)+asr(c,b,eps/2,R);
}

double ASR(double a,double b,double eps)
{
return asr(a,b,eps,simpson(a,b));
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);

int T_T;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
printf("%.3lf\n",2.*ASR(l,r,1e-6));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: