您的位置:首页 > 其它

uva 657 The die is cast

2014-12-27 10:47 477 查看

uva 657 The die is cast

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers.
Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture
of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels
connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.



A set S of pixels is connected if for every pair (a,b) of pixels in
S, there is a sequence

in
S such that a = a1 and b = ak , and
ai and ai+1 are connected for


.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal
connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy


.
The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.
Print a blank line after each test case.

Sample Input

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output

Throw 1
1 2 2 4


题目大意:判断色子的数值(所给出的个数不一定,色子的值有从小到大输出。

解题思路 :这题其实是之前那题油田的升级版,但是要注意的地方多了很多。

1)格式,题目要求每次“Throw”完后,都要空一行。

2)这题是四连块不是八连快,要读清楚题目。

3)DFS嵌套技巧。两个DFS互相嵌套,在DFS“X”时,如果遍历到“X”首先想到的是将这一点设为已访问,但如果直接将这一点变成

“*“会不会更好。(因为底下的特例1)

4)特例:

6 3

*X*X*X

*X*X*X

*X*X*X

5 5

XXXXX

XXXXX

XXXXX

XXXXX

6 3

X*X*X*

*X*X*X

X*X*X*

2 2

..

**

</pre><pre name="code" class="cpp"><span style="color:#000000;">#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define N 60
char gra

;
int m, n;
bool cmp(int a, int b) {
	return a < b;
}
int visit

, sum, flag = 0;
int DFS(int a, int b);
int DFS_X(int a, int b) {      //深度优先遍历X
	if (gra[a][b] != 'X' || visit[a][b]) return 0;
	gra[a][b] = '*';         //将X变为*
	if (a < n - 1) {
		DFS_X(a + 1, b);
	}
	if (a > 0) {
		DFS_X(a - 1, b);
	}
	if (b < m - 1) {
		DFS_X(a, b + 1);
	}
	if (b > 0) {
		DFS_X(a, b - 1);
	}
	return 0;
}
int DFS(int a, int b) {      //深度优先遍历*
	if (gra[a][b] == 'X' && !visit[a][b]) {   //遇到X进入X深度优先遍历
		DFS_X (a, b);
		sum++;
		return 0;
	}
	if (gra[a][b] != '*' || visit[a][b]) {
		return 0;
	}
	visit[a][b] = 1;
	for (int i = 0; i < 2; i++) {   // 防止由X变成的*没有遍历到
		if (a < n - 1) {
			DFS(a + 1, b);
		}
		if (a > 0) {
			DFS(a - 1, b);
		}
		if (b < m - 1) {
			DFS(a, b + 1);
		}
		if (b > 0) {
			DFS(a, b - 1);
		}
	}
	return sum;
}
int main() {
	int cnt;
	int SUM
, cnt2, cnt3;
	while (scanf("%d %d\n", &m, &n) != EOF, m, n) {
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < m; j++) {
				visit[i][j] = 0;
			}
			SUM[i] = 0;
		}
		cnt3 = 0;
		cnt2 = 0;
		cnt = 0;
		memset(gra, 0, sizeof(gra));
		for (int i = 0; i < n; i++) {
			gets(gra[cnt++]);
		}
		printf("Throw %d\n", flag + 1);
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < m; j++) {
				if (gra[i][j] == '*' && !visit[i][j]) {
					cnt3 = 1;
					sum = 0;
					SUM[cnt2++] = DFS(i, j);
				}
			}
		}	
		for (int i = 0; i < n ;i++) {        //只有X的情况
			for (int j = 0; j < m; j++) {
				if (gra[i][j] == 'X' && !visit[i][j]) {
					cnt3 = 1;
					SUM[cnt2]++;
					DFS_X(i, j);
					cnt2++;
				}	
			}
		}
		sort(SUM, SUM + cnt2, cmp);
		for (int i = 0; i < cnt2; i++) {
			if (i == 0) {
				printf("%d", SUM[i]);
			}
			else printf(" %d", SUM[i]);
		} 
		if (!cnt3) {
			printf("0");
		}
		printf("\n\n");
		flag++;
	}
	return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: