您的位置:首页 > 其它

HDU--1045--Fire Net--DFS

2014-12-27 09:25 393 查看


Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6802 Accepted Submission(s): 3845



Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


Sample Output

5
1
5
2
4

看着好像很厉害的样子。。。其实不难。dyx

#include <iostream>

using namespace std;
char map[10][10];//定义地图。
int n;//输入的几乘几的地图.
int ans;//用以输出最后的答案。
int wyx;//用已进行进行当前的计数。
int castle(int x,int y)
{
//进行判断的时候,先进行行的判断,再进行列的判断,也就是一个位置一个位置的扫过去。
for(int i=x;i<=n;i++)
{
//当位置为堡垒的时候。
if(map[i][y]==1)
return 0;
//当当前位置是墙的时候。
if(map[i][y]==2)
break;
}
for(int i=x;i>=1;i--)
{
if(map[i][y]==1)
return 0;
if(map[i][y]==2)
break;
}
for(int i=y;i<=n;i++)
{
if(map[x][i]==1)
return 0;
if(map[x][i]==2)
break;
}
for(int i=y;i>=1;i--)
{
if(map[x][i]==1)
return 0;
if(map[x][i]==2)
break;
}
//当所有的判断条件都不符合时,有两种情况。
//行列均无碉堡,可以放置,或者四方有墙壁可以挡住碉堡射出的子弹。则此位置也可以放置。
return 1;
}
void DFS()
{
if(wyx>ans)
ans=wyx;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
//只有当地图中的位置为0时,才可以进行循环,然后用castle进行判断是否当前位置可以放置一个碉堡,
if(!map[i][j]&&castle(i,j))
{
//如果可以放置,wyx++;
map[i][j]=1;
wyx++;
DFS();
//当一种情况判断完了之后,再返回到前面一种情况进行判断。
map[i][j]=0;
wyx--;
}
}
}
}

int main()
{
while(cin>>n&&n)
{
wyx=ans=0;
char dyx[10];//用以输入地图中的各种数据。
//在地图中,0表示领域为空什么都没有放置,1表示放置了碉堡,2表示为墙。
for(int i=1;i<=n;i++)
{
cin>>dyx;
for(int j=1;j<=n;j++)
{

//题意给定x为墙壁。如果不是墙壁,进行判定是否可以放置碉堡、
map[i][j]=(dyx[j-1]=='X'?2:0);
}
}
DFS();
cout<<ans<<endl;
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: