您的位置:首页 > 其它

HDU1162 Eddy's picture【Prim】

2014-12-25 16:18 246 查看
Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7231    Accepted Submission(s): 3656

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends
are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

 

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.

 

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

 

Sample Input

3

1.0 1.0

2.0 2.0

2.0 4.0

 

Sample Output

3.41

题目大意:给你N个点的坐标,求能使这N个点相连的所有边的最小距离是多少。

思路:先求出每个点和其他点的距离,存到图中,用Prim模板来做。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

struct Node
{
double x;
double y;
}A[110];

double G[110][110],low[110];
int vis[110];

void Prim(int N)
{
memset(vis,0,sizeof(vis));
int pos = 1;
vis[pos] = 1;
double ans = 0;
for(int i = 1; i <= N; i++)
if(i != pos)
low[i] = G[pos][i];

for(int i = 1; i < N; i++)
{
double Min = 0x7ffffff;
for(int j = 1; j <= N; j++)
{
if(!vis[j] && Min > low[j])
{
Min = low[j];
pos = j;
}
}
vis[pos] = 1;
ans += Min;
for(int j = 1; j <= N; j++)
{
if(!vis[j] && low[j] > G[pos][j])
low[j] = G[pos][j];
}
}
printf("%.2lf\n",ans);
}

int main()
{
int N;
double Dist,x,y;
while(cin >> N)
{
for(int i = 1; i <= N; i++)
{
for(int j = 1; j <= N; j++)
G[i][j] = 0x7fffff;
}
memset(A,0,sizeof(A));
for(int i = 1; i <= N; i++)
{
cin >> A[i].x >> A[i].y;
}
for(int i = 1; i <= N; i++)
{
for(int j = 1; j <= N; j++)
{
x = A[i].x - A[j].x;
y = A[i].y - A[j].y;
Dist = sqrt(x*x+y*y);
G[i][j] = Dist;
}
}
Prim(N);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: