您的位置:首页 > 其它

hdu 1114 存钱罐 完全背包入门

2014-12-25 16:08 176 查看
Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes
all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to
be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights
are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are
exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight
cannot be reached exactly, print a line "This is impossible.". 

 

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

 

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

 
题意就是给你一个存钱罐,告诉你存钱罐空的重量和满的重量。接着给你n种钱币的单价和重量,问你这个存钱罐最少能存多少。
一道完全背包,因为每种钱可以存任意个,只是要求算最少。要注意把dp初始化条件应该是无穷大,且dp[0]为0,因为存储罐空的时候钱只能是0,其余时候不可能有钱,所以给一个无穷大。状态转移方程为 : dp[j] = min(dp[j], dp[j - weight[i]] + value[i]);

//注意max要大点 , 一开始小了
#include <stdio.h>
#include <string.h>
#define MAX 655350

int dp[10001];
int value[501];
int weight[501];

int min(int a, int b)
{
return a > b ? b : a;
}

int main()
{
int t, n;
int i, j;
int first, last, w;

scanf("%d", &t);
while (t--)
{
scanf("%d %d", &first, &last);
w = last - first;

scanf("%d", &n);
for (i = 1; i <= n; i++)
{
scanf("%d %d", &value[i], &weight[i]);
}

for (i = 1; i <= w; i++)
{
dp[i] = MAX;
}
dp[0] = 0;

for (i = 1; i <= n; i++)
{
for (j = weight[i]; j <= w; j++)
{
dp[j] = min(dp[j], dp[j - weight[i]] + value[i]);
}
}

if (dp[w] < MAX)
{
printf("The minimum amount of money in the piggy-bank is %d.\n", dp[w]);
}
else
{
printf("This is impossible.\n");
}
}
return 0;
}<span style="color:#ff0000;">
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  完全背包 dp