您的位置:首页 > 其它

HDU 5019 Revenge of GCD 第n个公共约数

2014-12-24 22:10 405 查看

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1403 Accepted Submission(s): 389


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is
the largest positive integer that divides the numbers without a remainder.

---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= X, Y, K <= 1 000 000 000 000
Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
Sample Input
3
2 3 1
2 3 2
8 16 3


Sample Output
1
-1
2


/*
HDU 5019 第n个公共约数
第C大的公约数为x,最大公约数为g的话,那么x|g的,枚举g的因数 

最大公约数其实就是A和B分别进行素因子分解之后,能取到公共素因子乘起来得到的。
而对于任意A、B的公约数,那么肯定包含了部分的最大公约数所包含的素因子,因此x|g。
就是后面的因子 肯定包含前面的 
*/
#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
typedef __int64 LL;
vector<LL> v;
int main()
{
	LL a,b,c,r;
	int t;
//	freopen("test.txt","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d%I64d%I64d",&a,&b,&c);
		r=1;
		while(r!=0)
		{
			r=b%a;
			b=a;
			a=r;
		}
		//最大公约m1 
		v.clear();
		for(LL i=1;i*i<=b;i++)
		{
			if(b%i==0)
			{
				v.push_back(i);
				if(i*i!=b)
					v.push_back(b/i);
			}
		}
		sort(v.begin(),v.end());
		if(v.size()>=c)
			printf("%I64d\n",v[v.size()-c]);
		else
			printf("-1\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: