您的位置:首页 > 其它

二分查找:hdu 2141 Can you find it?

2014-12-23 20:43 429 查看
Can you find it?

[align=left]Problem Description[/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

 

[align=left]Input[/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there
are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

 

[align=left]Output[/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print
"NO".

 

[align=left]Sample Input[/align]

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

 

[align=left]Sample Output[/align]

Case 1:
NO
YES
NO

思路:

1.A+B=S-C,构造数组d[maxn*maxn]存储a[maxn]+b[maxn]的和的所有可能结果,将问题转换成在数组d[maxn*maxn]二分查找S-C[i],找到就输出YES,否则输出NO。

2.二分查找用STL函数binary_search(a,a+n,num)解决,不用手写二分查找函数;

3.注意a[i]+b[i]可能会溢出,最好用64位数组,不过int数组能过了。

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <vector>
#include <cstring>
#define maxn 550
using namespace std;
int a[maxn],b[maxn],c[maxn],d[maxn*maxn];
int main()
{
// freopen("input.txt","r",stdin);
int l,m,n;int cnt=0;
while(scanf("%d%d%d",&l,&n,&m)!=EOF){
for(int i=0;i<l;i++) scanf("%d",a+i);
for(int i=0;i<n;i++) scanf("%d",b+i);
for(int i=0;i<m;i++) scanf("%d",c+i);
for(int i=0;i<l;i++)
for(int j=0;j<n;j++)
d[i*l+j]=a[i]+b[j];
sort(d,d+l*n);
int T;cin>>T;
int s;
cout<<"Case "<<++cnt<<":"<<endl;
while(T--){
scanf("%d",&s);
bool ok=false;
for(int i=0;i<m;i++)
if(binary_search(d,d+l*n,s-c[i])) {ok=true;break;}
if(ok) printf("YES\n");else printf("NO\n");
}
}
return 0;
}</span>


新手敲代码,分析题目,望高手不吝赐教,谢谢!




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息