您的位置:首页 > 其它

【连通图|关节点】POJ-1523 SPF

2014-12-21 21:30 417 查看
SPF

Time Limit: 1000MS Memory Limit: 10000K
   
Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from
communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected
network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 



Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers
will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when
that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output
Network #1
SPF node 3 leaves 2 subnets

Network #2
No SPF nodes

Network #3
SPF node 2 leaves 2 subnets
SPF node 3 leaves 2 subnets

————————————————————————————————————————————————————————
题意:求出给出图中的关节点,以及去掉该点之后图被分为多少个连通分量。
思路:Tarjan算法求关节点模板题,对于分为多少个连通分量,一开始SB到想用并查集什么的,其实只需要看一个点“能够成为关节点多少次”就行了。将iscut数组改成int型,每次加1就行了。
代码如下:
/*
* ID: j.sure.1
* PROG:
* LANG: C++
*/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define Mem(f, x) memset(f, x, sizeof(f))
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 1111;
int G

, deep, dfn
, low
;
int iscut
;
int n;

int dfs(int u, int fa)
{
int lowu = dfn[u] = ++deep;
int son = 0;
for(int v = 0; v < n; v++) if(G[u][v]) {
if(!dfn[v]) {
son++;
int lowv = dfs(v, u);
lowu = min(lowu, lowv);
if(lowv >= dfn[u]) iscut[u]++;
continue ;
}
if(dfn[v] < dfn[u] && v != fa)
lowu = min(lowu, dfn[v]);
}
if(fa == -1 && son == 1) iscut[u] = 0;
return low[u] = lowu;
}

int main()
{
#ifdef J_Sure
freopen("000.in", "r", stdin);
//freopen("999.out", "w", stdout);
#endif
int a, b;
int kase = 1;
while(scanf("%d", &a), a) {
n = a;
Mem(G, 0);
deep = 0;
scanf("%d", &b);
n = max(n, b);
G[a-1][b-1] = G[b-1][a-1] = 1;
while(scanf("%d", &a), a) {
n = max(n, a);
scanf("%d", &b);
n = max(n, b);
G[a-1][b-1] = G[b-1][a-1] = 1;
}
for(int i = 0; i < n; i++) {
iscut[i] = low[i] = dfn[i] = 0;
}
dfs(b-1, -1);
printf("Network #%d\n", kase++);
bool flag = false;
for(int i = 0; i < n; i++) {
if(iscut[i]) {
flag = true;
printf("  SPF node %d leaves %d subnets\n", i+1, iscut[i]+1);
}
}
if(!flag) puts("  No SPF nodes");
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: