您的位置:首页 > 其它

hdu1171 Big Event in HDU 01背包

2014-12-20 23:44 295 查看
Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the
facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

 

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

Sample Output

20 10
40 40

 
简单的说就是给你一大堆数,让你尽可能的均分。很简单的01背包,本来没什么思路,突然想剪剪指甲,结果剪的时候想到了。
求出一大堆数的和为v,转化为01背包,背包容量上限为v/2,求出来的就是最接近v/2的分法,看来以后要多剪一下指甲。。。

#include <stdio.h>
#include <string.h>

int dp[60001];
int val[60001];

int max(int a, int b)
{
return a > b ? a : b;
}

int main()
{
int n, t, m;
int i, j, count;
int v, v2;

while (scanf("%d", &n) != EOF && n >= 0)
{
count = v = 0;
for (i = 0; i < n; i++)
{
scanf("%d %d", &t, &m);

v += t * m;

for (j = 0; j < m; j++)
{
val[++count] = t;
}
}

memset(dp, 0, sizeof(dp));

v2 = v / 2;                                   //嘿嘿,自己想到的,得意一个~
for (i = 1; i <= count; i++)
{
for (j = v2; j >= val[i]; j--)
{
dp[j] = max(dp[j], dp[j - val[i]] + val[i]);
}
}

printf("%d %d\n", v - dp[v2], dp[v2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息