您的位置:首页 > 其它

UVa 202 Repeating Decimals(循环小数)

2014-12-20 01:31 423 查看
Description







The decimal expansion of the fraction 1/33 is

, where the

is
used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating
cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.



Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus
for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end
of input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire
repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins
- it will begin within the first 50 places - and place ``...)" after the 50th digit.
Print a blank line after every test case.

Sample Input

76 25
5 43
1 397


Sample Output

76/25 = 3.04(0)
1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle



刚看到这个题的时候觉得好难好麻烦啊又是模拟,然后就把这个专题剩下的题都做完了再做这一个。。

研究了一下除法的特点,发现在计算小数部分的时候,如果某次得到的余数在之前出现过,那么这个小数就开始循环了,觉得挺简单,但是做起来发现没那么容易,因为没考虑周全,这个题也耽误了不少时间。

一开始直接用一个变量存储整数部分,然后用一个数组来存小数部分,把取整后剩下的部分作为后面求解的原始数,进行模拟运算,但WA后发现这对于整除的数不适用,再加上自己括号控制的不好,位置都会加错= =,最后整理了一下思路,重新敲了一遍,用了一个标记数组(因为看到了两数小于3000,所以余数的范围也不会超过它的,开数组变成了可能~),用于快速查询此余数是否在之前得出并且得到他的位置,然后循环模拟,当出现被标记且不为0的时候,就可以跳出了,得到循环小数的起始位置和终止位置,然后在合适的位置安排括号就可以了,另外注意超过50为要打...控制一下就好,代码如下:

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX=3003;
int decimal[MAX];//存储商数
int remainder[MAX];//存储余数
int mark[MAX*10];//标记数组

int main()
{
ios::sync_with_stdio(false);
int quotient,start,ends,a,b,i;
while(cin>>a>>b)
{
memset(mark,-1,sizeof(mark));//初始化为无标记
decimal[0]=quotient=a/b;//将整数部分单独拿出用于输入,并存到数组里用于模拟计算
mark[remainder[0]=a]=0;//第0个余数为被除数,标记(位置)0
for(i=1;true;i++)
{
remainder[i]=(remainder[i-1]-b*decimal[i-1])*10;//模拟除法,列一个除法竖式验算一下就明了了
decimal[i]=remainder[i]/b;
if((start=mark[remainder[i]])>0)//当所得余数已经被标记并且不是第0个,说明开始循环了,将这个位置赋给start并跳出
break;
mark[remainder[i]]=i;//将余数做上标记
}
cout<<a<<"/"<<b<<" = "<<quotient<<".";
for(ends=i,i=1;i<start;i++)//到start之前输出不循环的那部分小数
cout<<decimal[i];
for(cout<<"(",i=start;i<ends;cout<<decimal[i],i++)//对循环小数的输出控制
if(i>50)
{
cout<<"...";
break;
}
cout<<")"<<endl<<" "<<ends-start<<" = "<<"number of digits in repeating cycle"<<endl<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: