您的位置:首页 > 其它

ACM水题系列 HDOJ 1326

2014-12-20 00:01 344 查看

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7586 Accepted Submission(s): 1756
Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I\'ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a
real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of
bricks moved. Can you help?



Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line between each set.

Sample Input

6
5 2 4 1 7 5
0


Sample Output

Set #1
The minimum number of moves is 5.





这道题,我的思路是先求平均值,然后遍历所有数,不用排序,比如,a比平均值n大,就把a-n存在sum里,比平均值小就continue。


#include <iostream>
#include <string.h>
using namespace std;
int main()
{
int t,i,flag = 1;
while(cin>>t&&t!=0){
int a[50],sum = 0,ans=0;
memset(a,0,sizeof(a));
for(i=0;i<t;i++){
cin>>a[i];
sum+=a[i];
}
sum/=t;
for(i=0;i<t;i++){
if(sum>a[i])continue;
else{
ans += a[i]-sum;
}
}
cout<<"Set #"<<flag<<endl<<"The minimum number of moves is "<<ans<<"."<<endl<<endl;
flag++;
}

return 0;
}


[/code]


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: