您的位置:首页 > 其它

poj-1703 find them,catch them!

2014-12-19 15:08 399 查看
Find them, Catch them

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 32636
Accepted: 10073
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1

5 5

A 1 2

D 1 2

A 1 2

D 2 4

A 1 4

Sample Output

Not sure yet.

In different gangs.

In the same gang.

[b]题目大意:


在这个城市里有两个黑帮团伙,现在给出N个人,问任意两个人他们是否在同一个团伙

输入D x y代表x于y不在一个团伙里

输入A x y要输出x与y是否在同一团伙或者不确定他们在同一个团伙里

解决思路:经典的并查集题,把确定关系的人放到一棵树里,并用权值rela[]表示关系。

二者在同一棵树里,并且权值相等:同伙。

二者不在同一棵树里,并且权值不相等:敌人。

二者不在同一棵树里:关系不确定。

#include<iostream>
#include <cstdio>
using namespace std;
#define MAXL 100010//开得不够大就RE(话说我开始开了50050。。。)
int uf[MAXL], rela[MAXL];

void uf_init(int n);
int uf_find(int x);
void uf_union(int x, int y, int px, int py);

int main()
{
int T, n, m;
char re;
int a, b, pa, pb;
scanf("%d", &T);
while (T--)
{
scanf("%d%d\n", &n, &m);
uf_init(n);
for (int i = 0; i < m; i++)
{
scanf("%c%d%d\n", &re, &a, &b);
pa = uf_find(a);
pb = uf_find(b);
if (re == 'D')
{
uf_union(a, b, pa, pb);
}
else if (re == 'A')
{
if (2 == n)
cout << "In different gangs." << endl;
else if (pa == pb)
{
if (rela[b] == rela[a])
cout << "In the same gang." << endl;
else
cout << "In different gangs." << endl;
}
else
cout << "Not sure yet." << endl;
}
}
}

}

void uf_init(int n)
{
for (int i = 1; i <= n; i++)
{
uf[i] = i;
rela[i] = 0;
}
}

int uf_find(int x)
{
if (x == uf[x])
return x;
int tmp = uf[x];
uf[x] = uf_find(tmp);
rela[x] = (rela[x] + rela[tmp]) % 2;
return uf[x];
}

void uf_union(int x, int y, int px, int py)
{
uf[px] = py;
rela[px] = (rela[y] - rela[x] + 1) % 2;
}
注意:

cin会TLE,加了cin加速还是不行。。。

scanf的引号中要加\n,否则在循环中会因为丢失回车而导致RE。不过用cin就不会出现这个问题。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: