您的位置:首页 > 其它

HDU 1009 FatMouse' Trade【贪心】

2014-12-17 07:24 369 查看
解题思路:一只老鼠共有m的猫粮,给出n个房间,每一间房间可以用f[i]的猫粮换取w[i]的豆,问老鼠最多能够获得豆的数量 sum

即每一间房间的豆的单价为v[i]=f[i]/w[i],要想买到最多的豆,一定是先买最便宜的,再买第二便宜的,再买第三便宜的

-----m的值为0的时候求得的sum即为最大值 所以先将v[i]从小到大排序。

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 45970 Accepted Submission(s): 15397
[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

[align=left]Sample Output[/align]

13.333 31.500

#include<stdio.h>
void bubblesort(double v[],int w[],int f[],int n)
{
int i,j;
double t;
for(i=1;i<=n;i++)
{
for(j=i+1;j<=n;j++)
{
if(v[i]>v[j])
{
t=v[i];
v[i]=v[j];
v[j]=t;

t=f[i];
f[i]=f[j];
f[j]=t;

t=w[i];
w[i]=w[j];
w[j]=t;
}
}
}
}
int main()
{
int n,m,i,j,w[1000],f[1000];
double v[1000],sum;
while(scanf("%d %d",&m,&n)!=EOF&&(n!=-1)&&(m!=-1))
{
for(i=1;i<=n;i++)
{
scanf("%d %d",&w[i],&f[i]);
v[i]=f[i]*1.0/w[i];
}
bubblesort(v,w,f,n);

sum=0;
for(i=1;i<=n&&v[i]<=m&&m>0;i++) //如果v[i]>m,则单价大于总价,不能进行交换,跳出循环
{

if(m>=f[i]) //总价能够买到该房间所有的豆
{
sum+=w[i];
m=m-f[i];
}
else
{
sum+=m*1.0/v[i]; //总价只能买到该房间部分的豆,说明买完这间房间的豆,总价也用完了
m=0;
}
}
printf("%.3lf\n",sum);
}
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: