您的位置:首页 > 编程语言 > Java开发

hdu 1102 A + B Problem II (java大数)

2014-12-15 19:38 323 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 230178 Accepted Submission(s): 44173



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.



Sample Input
2
1 2
112233445566778899 998877665544332211




Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
代码一:
import java.util.*;
import java.math.*;

public class Main
{
	public static void main(String args[])
	{
		Scanner cin=new Scanner(System.in);
		int t;
		int i;
		BigInteger a,b;
		t=cin.nextInt();
		for(i=1;i<=t;i++)
		{
			a=cin.nextBigInteger();
			b=cin.nextBigInteger();
			System.out.println("Case "+i+":");
			System.out.println(a+" + "+b+" = "+a.add(b));
			if(i!=t)
			{
				System.out.println();
			}
			
		}
	}
}


A了,但神奇的是代码二PE,还求大神指点迷津
代码二:[code]import java.util.*;
import java.math.*;

public class Main
{
public static void main(String args[])
{
Scanner cin=new Scanner(System.in);
int t;
int i;
BigInteger a,b,s;
t=cin.nextInt();
for(i=1;i<=t;i++)
{
a=cin.nextBigInteger();
b=cin.nextBigInteger();
s=a.add(b);
if(i==t)
{
System.out.println("Case "+i+":");
System.out.println(a+" + "+b+" = "+s);
}
else
{
System.out.println("Case "+i+":");
System.out.println(a+" + "+b+" = "+s+"\n");
}

}
}
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: