您的位置:首页 > 产品设计 > UI/UE

poj 1458 Common Subsequence(最长公共子序列)

2014-12-13 23:40 295 查看
Common Subsequence

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 39667Accepted: 15954
http://poj.org/problem?id=1458

Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another
sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X
= < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated
by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate
line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0

Source
Southeastern
Europe 2003

/*

最长公共子序列 

*/
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
char s1[1000];
char s2[1000];
int dp[1000][1000];
int main()
{
while(~scanf("%s%s",s1,s2))
{
int i,j;
int len1=strlen(s1);
int len2=strlen(s2);
for(i=0;i<=len1;i++)
dp[i][0]=0;
for(i=0;i<=len2;i++)
dp[0][i]=0;

for(i=0;i<len1;i++)
for(j=0;j<len2;j++)
{
if(s1[i]==s2[j])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
printf("%d\n",dp[len1-1][len2-1]);//dp[len1-1][len2-1]最长子序列 长度
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: