您的位置:首页 > 其它

【习题3-1】 UVA - 1585 Score

2014-12-13 22:38 281 查看
Description

There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is
correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ` O' and ` X' and the length of the string
is more than 0 and less than 80. There is no spaces between ` O' and ` X'.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55
30

用t_score记录当前分数,score记录总分数即可。。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int main()
{
int T, score, l, t_score, i;
char s[100];
cin >> T;
while(T--)
{
cin >> s;

l = strlen(s);
for(i = 0, score = t_score = 0; i < l; i++)
{
if(s[i] == 'O')
{
t_score++;
score += t_score;
}
else
t_score = 0;
}
cout << score << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVA 紫书