您的位置:首页 > 其它

poj 1065 Wooden Sticks

2014-12-11 22:54 239 查看
Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

思路:将木棍放在机器里处理,第一根需要一分钟,剩余的木头长度和重量如果大于等于前边放入的长度和重量,就不用费时间;否则需要一分钟,计算给出一组数花费用的最少时间;用贪心算出最少降序序列个数!首先对数组进行排序先按照长度,如果长度相等就按照重量从小到大

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct dot
{
int l;
int w;
bool flag;
};
bool  cmp(dot a,dot b)
{
if(a.l!=b.l)
return a.l<b.l;
else
return a.w<b.w;
}
int main()
{
dot a[8000];
int test;
int n,j;
cin>>test;
while(test--)
{
memset(a,0,sizeof(a));
cin>>n;
for(int i=0;i<n;i++)
{
cin>>a[i].l>>a[i].w;
a[i].flag=0;
}
sort(a,a+n,cmp);
int time=0;
int k;
for(int i=0;i<n;i++)
{
if(a[i].flag==1)
continue;
k=a[i].w;
time++;
a[i].flag=1;
for(j=1;j<n;j++)
{
if(a[j].w>=k&&a[j].flag==0)
{
k=a[j].w;
a[j].flag=1;
}
}

}
cout<<time<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: