您的位置:首页 > 其它

HDU 4791 Alice's Print Service

2014-12-11 21:14 465 查看


Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1426 Accepted Submission(s): 341



Problem Description

Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an
extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 <
... < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price
when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.

Output

For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input

1
2 3
0 20 100 10
0 99 100


Sample Output

0
1000
1000


Source

2013 Asia Changsha Regional Contest

题意:就是要打印n张纸,已知打印超过s1,s2,s3,s4.....sn张纸的话,单价分别是p1,p2,p3....pn,问答打印多少张花费最小。

思路:记录后缀的最小si*pi, 首先二分到对应的张数位置....然后看多买能不能更省.. 记得用long long

代码:

<span style="font-size:18px;"><strong>#include <iostream>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cstring>
#include <stdio.h>
#include <cmath>
#include <math.h>
#define rep(i,a,b) for(int i=(a);i<(b);++i)
#define rrep(i,b,a) for(int i = (b); i >= (a); --i)
#define clr(a,x) memset(a,(x),sizeof(a))
#define LL long long
#define eps 1e-10
using namespace std;
const int maxn = 100000 + 5;
int s[maxn],p[maxn];
LL mincost[maxn];

inline LL min(LL a, LL b) { return a < b ? a : b; }
inline LL max(LL a, LL b) { return a > b ? a : b; }
void read_int(int & x)
{
char ch = getchar();
while (ch < '0' || ch > '9') ch = getchar();
x = ch - '0'; ch = getchar();
while ('0' <= ch && ch <= '9') {
x = 10 * x + ch - '0';
ch = getchar();
}
}

int n,m;
void input()
{
scanf("%d%d",&n,&m);
rep(i,1,n+1) {
//   scanf("%d%d",s+i,p+i);
read_int(s[i]); read_int(p[i]);
}
mincost
= (LL) s
* p
;
rrep(i,n-1,1) mincost[i] = min(mincost[i+1],(LL) s[i] * p[i]);
}

void solve()
{
while (m--) {
int q; read_int(q);//scanf("%d",&q);
if (q >= s
) {
printf("%I64d\n",(LL) p
* q);
continue;
}
int i = upper_bound(s+1,s+1+n,q) - s - 1;
LL ans = min((LL)p[i] * q, mincost[i+1]);
printf("%I64d\n",ans);
}
}

int main()
{
#ifdef ACM
freopen("in.txt", "r", stdin);
#endif // ACM
int T; cin >> T;
while (T--) {
input();
solve();
}
}</strong></span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: