您的位置:首页 > 其它

UVA572 HDU1241 POJ1562 Oil Deposits【DFS】

2014-12-11 17:47 423 查看
 Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a
grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise  

 and 

. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output 

0

1

2

2

题目大意:给你一个m行n列的字符矩阵,统计字符“@”组成多少个八连块。

思路:DFS上下左右斜方向寻找八连块。vis数组记录的是联通块的编号。若

暂未搜到则为0。用dx,dy二重循环表示八个方向。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

char map[110][110];
int vis[110][110],M,N;

void dfs(int i,int j,int count)
{
if(i < 0 || i > M-1 || j < 0 || j > N-1)
return;
if(vis[i][j] ||map[i][j]!='@')
return;
vis[i][j] = count;
for(int dx = -1; dx <= 1; dx++)
{
for(int dy = -1; dy <= 1; dy++)
{
if(dx!=0 || dy!=0)
dfs(i+dx,j+dy,count);
}
}
}
int main()
{
while(~scanf("%d%d",&M,&N) &&(M||N))
{
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i = 0; i < M; i++)
scanf("%s",map[i]);
int count = 0;
for(int i = 0; i < M; i++)
{
for(int j = 0; j < N; j++)
{
if(vis[i][j]==0 && map[i][j]=='@')
dfs(i,j,++count);
}
}
printf("%d\n",count);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: