您的位置:首页 > 其它

UVA - 575 - Skew Binary (简单数论!)

2014-12-07 20:46 591 查看
UVA - 575

Skew Binary

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description







Skew Binary

When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,



When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example,



In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a
2. For example,



The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing
to do with the current problem.)

Input

The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output

For each number, output the decimal equivalent. The decimal value of n will be at most 2 31 - 1 = 2147483647.

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0


Sample Output

44
2147483646
3
2147483647
4
7
1041110737


Miguel A. Revilla

1998-03-10

Source

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Mathematics :: Ad Hoc Mathematics Problems :: Base
Number Variants

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 1. Elementary Problem Solving :: Maths -
Number Theory

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Mathematics :: Ad Hoc Mathematics Problems :: Base
Number Variants
AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define LL long long
using namespace std;

int main()
{
	char a[40];
	while(scanf("%s", a)!=EOF)
	{
		if(strlen(a)==1 && a[0] == '0')break;
		int len = strlen(a);
		LL bei=2, ans = 0;
		for(int i=len-1; i>=0; i--)
		{
			ans += ( (bei-1) * (a[i]-'0') );
			bei*=2;
		}
		printf("%lld\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: