您的位置:首页 > 其它

HDU 1051 Wooden Sticks(How to use 快排)

2014-12-07 19:52 274 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2331 Accepted Submission(s): 908
[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


[align=left]Sample Output[/align]

2
1
3


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>       //1.使用qsort()需 #include<algorithm> OR #include<stdlib.h>
using namespace std;
struct tim
{
int x,y;
}a[11111];
int tab[50001];
int comp(const void *a,const void *b)  //2.定义比较函数
{
tim *x=(tim*)a,*y=(tim*)b;
if(x->x!=y->x)
return x->x-y->x;
return x->y-y->y;
}
//再举个简单的栗子:
/*
int compare(const void *a,const void *b){
return *(int*)a - *(int*)b;
//if return *(int*b) - *(int*a) ,then the array will be sortted in decreasing order (递减序列)
}
*/
int main()
{
int i,j,m,n,k,t;
cin>>k;
while(k--)
{
cin>>n;
for(i=1;i<=n;i++)
cin>>a[i].x>>a[i].y;
/*3. 实参1.传要排序的数组  +1表示从第一个开始排序
2.n 数组元素个数
3.一个元素的大小
4.比较函数  OK
快排的实现请参照 http://blog.csdn.net/u012400327/article/details/22619497 */
qsort(a+1, n, sizeof(tim), comp);
memset(tab, 0, sizeof(tab));
m=j=0;
while(j<n)
{
m++;
i=1;
while(tab[i]==1)
i++;
int temp1=i;
tab[i]=1;
j++;
i++;
//    cout<<temp1<<' '<<i<<' '<<j<<endl;
while(i<=n)
if(tab[i]==0)
{
{
if(a[i].x>=a[temp1].x&&a[i].y>=a[temp1].y)
{
temp1=i;
tab[i]=1;
j++;
}
}
i++;
}
else
i++;
}
cout<<m<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: