您的位置:首页 > 其它

hdu 1240 Asteroids! (bfs)

2014-12-07 12:34 281 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1240

Asteroids!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3549 Accepted Submission(s):
2354


[align=left]Problem Description[/align]
You're in space.
You want to get home.
There are
asteroids.
You don't want to hit them.

[align=left]Input[/align]
Input to this problem will consist of a (non-empty)
series of up to 100 data sets. Each data set will be formatted according to the
following description, and there will be no blank lines separating data
sets.

A single data set has 5 components:

Start line - A single
line, "START N", where 1 <= N <= 10.

Slice list - A series of N
slices. Each slice is an N x N matrix representing a horizontal slice through
the asteroid field. Each position in the matrix will be one of two
values:

'O' - (the letter "oh") Empty space

'X' - (upper-case)
Asteroid present

Starting Position - A single line, "A B C", denoting the
<A,B,C> coordinates of your craft's starting position. The coordinate
values will be integers separated by individual spaces.

Target Position -
A single line, "D E F", denoting the <D,E,F> coordinates of your target's
position. The coordinate values will be integers separated by individual
spaces.

End line - A single line, "END"

The origin of the
coordinate system is <0,0,0>. Therefore, each component of each coordinate
vector will be an integer between 0 and N-1, inclusive.

The first
coordinate in a set indicates the column. Left column = 0.

The second
coordinate in a set indicates the row. Top row = 0.

The third coordinate
in a set indicates the slice. First slice = 0.

Both the Starting Position
and the Target Position will be in empty space.

[align=left]Output[/align]
For each data set, there will be exactly one output
set, and there will be no blank lines separating output sets.

A single
output set consists of a single line. If a route exists, the line will be in the
format "X Y", where X is the same as N from the corresponding input data set and
Y is the least number of moves necessary to get your ship from the starting
position to the target position. If there is no route from the starting position
to the target position, the line will be "NO ROUTE" instead.

A move can
only be in one of the six basic directions: up, down, left, right, forward,
back. Phrased more precisely, a move will either increment or decrement a single
component of your current position vector by 1.

[align=left]Sample Input[/align]

START 1

O
0 0 0

0 0 0
END
START 3

XXX

XXX
XXX
OOO
OOO

OOO

XXX
XXX

XXX

0 0 1
2 2 1
END

START 5

OOOOO

OOOOO

OOOOO

OOOOO

OOOOO

OOOOO
OOOOO

OOOOO

OOOOO

OOOOO

XXXXX

XXXXX
XXXXX

XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

[align=left]Sample Output[/align]

1 0

3 4

NO ROUTE

题目大意:在太空想回家,要避开星空中的行星。给了一张三维的地图,X代表行星区,O代表空白,然后给出起点和终点的坐标。
   题目要求判断能否到达目的地,如果可以就输出N和最小的步数,否则输出NO ROUTE。
题目思路:大致就是一个普通的广搜就ok了,来找到最小的步数,其次的话就是注意输入,还有一个以"END"结束一个输入。

详见代码。

#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;

int dir[6][3]={0,0,1,0,0,-1,0,1,0,0,-1,0,1,0,0,-1,0,0};
char Map[25][25][25];
int sx,sy,sz,ex,ey,ez,N,flag,step;
struct node{
int x,y,z,t;
}s,ss;

void bfs()
{
queue<node>q,qq;
s.x=sx;
s.y=sy;
s.z=sz;
s.t=0;
q.push(s);
if (sx==ex&&sy==ey&&sz==ez)
{
flag=1;
step=0;
return ;
}
while (!q.empty())
{
s=q.front();
q.pop();
//cout<<"1"<<endl;
for (int i=0;i<6;i++)
{
int x=s.x+dir[i][0];
int y=s.y+dir[i][1];
int z=s.z+dir[i][2];
if (x>=0&&x<N&&y>=0&&y<N&&z>=0&&z<N&&Map[z][y][x]!='X')
{
ss.x=x;
ss.y=y;
ss.z=z;
ss.t=s.t+1;
Map[z][y][x]='X';
if (x==ex&&y==ey&&z==ez)
{
flag=1;
step=ss.t;
return ;
}
q.push(ss);
}
}
}
}

int main ()
{
char str[15],ch[15];

while (scanf("%s%d",str,&N)!=EOF)
{
//flag=0;
for (int i=0;i<N;i++)
for (int j=0;j<N;j++)
scanf("%s",Map[i][j]);
scanf("%d%d%d",&sx,&sy,&sz);
scanf("%d%d%d",&ex,&ey,&ez);
scanf("%s",ch);
flag=0;
bfs();
if (flag==1)
printf ("%d %d\n",N,step);
else
printf ("NO ROUTE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: