您的位置:首页 > 其它

HDU 2069 Coin Change

2014-12-06 22:13 309 查看


Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14228 Accepted Submission(s): 4764



Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.



Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.


Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.


Sample Input
11
26




Sample Output
4
13




Author
Lily


Source
浙江工业大学网络选拔赛

解题思路:
其实暴力枚举就好,但是听说还能用母函数来做,QAQ可惜我不会组合数学,所以母函数的知识到寒假在补上吧,先拿暴力来一发~

代码:
# include<cstdio>
# include<iostream>

using namespace std;

int a[6];

void dabiao()
    {
        a[1] = 50;
        a[2] = 25;
        a[3] = 10;
        a[4] = 5;
        a[5] = 1;
    }
int ans;
int n;

int main(void)
{
    dabiao();

    while ( cin>>n )
        {
            if ( n == 0 )
                ans = 1;
           else
           {
               ans = 0;
               for ( int i = n/50;i >= 0;i-- )
               {
                   for ( int j = (n-i*50)/25;j >= 0;j-- )
                   {
                       for ( int k = ( n- j*25-i*50)/10;k >= 0;k-- )
                       {
                           for ( int l = ( n- j*25-i*50 - k*10 )/5;l >= 0;l-- )
                                {
                                    if ( i+j+k+l+(n- j*25-i*50 - k*10-l*5) <= 100 )
                                            ans++;
                                }
                       }
                   }
               }
           }

           cout<<ans<<endl;
        }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: