您的位置:首页 > 其它

hdu-2069-Coin Change

2014-12-06 16:59 281 查看

Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14224 Accepted Submission(s): 4762

[align=left]Problem Description[/align]
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

[align=left]Input[/align]
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

[align=left]Output[/align]
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

[align=left]Sample Input[/align]

11
26

[align=left]Sample Output[/align]

4
13
#include<iostream>
using namespace std;
int main()
{
int n,a,b,c,d,e,sum;
while(cin>>n)
{
sum=0;
for(a=0;a*50<=n;a++)
for(b=0;b*25<=n;b++)
for(c=0;c*10<=n;c++)
for(d=0;d*5<=n;d++)
if(n+a+b+c+d-a*50-b*25-c*10-d*5<=100&&n-a*50-b*25-c*10-d*5>=0)
sum++;
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: