您的位置:首页 > 其它

Binary String Matching

2014-12-06 16:09 169 查看


Binary String Matching

时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is
‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And
it is guaranteed that B is always longer than A.
输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int main()
{
int n;
char A[11];
char B[1100];
char *p;
cin>>n;
while(n--)
{
int count=0;
cin>>A>>B;
p=strstr(B,A);
while(p)
{
count++;
p=p+1;
p=strstr(p,A);
}
cout<<count<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: