您的位置:首页 > 其它

poj 1703 Find them, Catch them 【并查集拓展】

2014-12-06 13:38 399 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 32514Accepted: 10036
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

题意:如果输入D a b 表示a和b不是在一个帮派里面,输入A a b就是询问a和b是不是在一帮派里面。

一般用到并查集都是询问是不是连通什么的,但这道题是考察并查集的另外一项特性,求与祖先节点的距离。

参考 http://www.cnblogs.com/dongsheng/archive/2012/08/08/2627917.html

和2492 几乎一样

代码:

#include <cstdio>
#include <cstring>
const int M = 100100;

int fat[M], ral[M];

int f(int x){
    if(fat[x] == x) return fat[x];
    else{
        int temp = fat[x];
        fat[x] = f(fat[x]);
        ral[x] = (ral[temp]+ral[x])%2;
        return fat[x];
    }
}

int main(){
    int t, n, m;
    scanf("%d", &t);
    while(t --){
        scanf("%d%d", &n, &m);
        int i;
        for(i = 0; i < M; i ++) fat[i] = i;
        memset(ral, 0, sizeof(ral));
        char ch[2];
        int a, b;
        while(m --){
            scanf("%s %d %d", ch, &a, &b);
            if(ch[0] == 'A'){
                int x = f(a); int y = f(b);
                if(x == y){
                    if(ral[a] == ral[b]){
                    puts("In the same gang.");
                    }
                    else puts("In different gangs.");
                }
                else printf("Not sure yet.\n");
            }
            else {
                int x = f(a); int y = f(b);
                if(x != y){
                    ral[x] = (ral[a]+ral[b]+1)%2;
                    fat[x] = y;
                }
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: