您的位置:首页 > 其它

poj 1426 Find The Multiple

2014-12-05 21:59 357 查看
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

找到任意n的倍数m,但是m由十进制0,1组成
#include <iostream>
#include <stdio.h>
#include <queue>
using namespace std;
long long n;
void bfs()
{
queue<long long>q;
q.push(1);
long long temp;
while (!q.empty())
{
temp=q.front();
q.pop();
if(temp%n==0)
{
printf("%lld\n",temp);
return;
}
q.push(temp*10);
q.push(temp*10+1);
}
}
int main()
{
while(scanf("%lld",&n) && n)
{
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: