您的位置:首页 > 其它

HDOJ 5100 Chessboard 构造

2014-12-05 00:06 253 查看
MATRIX67大神:   http://www.matrix67.com/blog/archives/5900


Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 538    Accepted Submission(s): 241


Problem Description

Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares
tiled.

 

Input

There are multiple test cases in the input file.

First line contain the number of cases T (T≤10000). 

In the next T lines contain T cases , Each case has two integers n and k. (1≤n,k≤100)

 

Output

Print the maximum number of chessboard squares tiled.

 

Sample Input

2
6 3
5 3

 

Sample Output

36
24

 

Source

BestCoder Round #17

 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int main()
{
int T_T;
int n,k;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%d%d",&n,&k);
if(k>n)
{
puts("0");
continue;
}
int r=n%k;
if(r>k/2) r=k-r;
printf("%d\n",n*n-r*r);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: