您的位置:首页 > 编程语言 > C语言/C++

poj-1338-Ugly Numbers

2014-12-04 20:45 323 查看
Ugly Numbers

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20878 Accepted: 9266
Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 

1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 

shows the first 10 ugly numbers. By convention, 1 is included. 

Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
Sample Input
1
2
9
0

Sample Output
1
2
10

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
int ugly[1510];
int main()
{
int n;

memset(ugly,0,sizeof(ugly));
int a,b,c;
a=b=c=1;
ugly[1]=1;
for(int i=2;i<=1500;i++)
{
ugly[i]=min(ugly[a]*2,min(ugly[b]*3,ugly[c]*5));
if(ugly[i]==ugly[a]*2)  a++;
if(ugly[i]==ugly[b]*3)  b++;
if(ugly[i]==ugly[c]*5)  c++;

}
while(~scanf("%d",&n),n)
{
printf("%d\n",ugly
);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj c++