您的位置:首页 > 其它

2014ACM/ICPC亚洲区北京站-重现赛 K(hdu 5122)

2014-12-04 12:58 447 查看


K.Bro Sorting

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 297 Accepted Submission(s): 170



Problem Description

Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after
this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence
in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .

Input

The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 106.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.

Sample Input

2
5
5 4 3 2 1
5
5 1 2 3 4


Sample Output

Case #1: 4
Case #2: 1

HintIn the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.


Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题意:让你用一个数字依次往后交换直到后面的数比它大的方法来使数列成为递增序列。
做法:首先设最后那个值设为初始min,然后从n-1扫到1,如果当前数值比min大则ans+1,否则min更新为当前数值。
#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <stack>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL long long
#define inf 0x0f0f0f0f
using namespace std;
int num[1000005];
int main()
{
int t,cas,i,n,min1,ans;
scanf("%d",&t);
for(cas=1;cas<=t;cas++)
{
ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&num[i]);
min1=num
;
for(i=n-1;i>=1;i--)
{
if(num[i]>min1)
ans++;
else
min1=num[i];
}
printf("Case #%d: %d\n",cas,ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: