您的位置:首页 > 其它

Power Strings(POJ2406)(KMP)

2014-12-04 00:42 330 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 33623Accepted: 13966
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source

Waterloo local 2002.07.01

KMP,next表示模式串如果第i位(设str[0]为第0位)与文本串

第j位不匹配则要回到第next[i]位继续与文本串第j位匹配。

则模式串第1位到next
与模式串第n-next
位到n位是匹配的。

如果n%(n-next
)==0,则存在重复连续子串,长度为n-next


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int next[1000002];
char s[1000002];
int len;
int get_next(char *s)
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<len)
	{
		if(j==-1||s[i]==s[j])
		{
		   i++;
		   j++;
		   next[i]=j;
	    }
	    else
	       j=next[j];
	}
	if(len%(len-next[len])==0)
	return len/(len-next[len]);
	else
	return 1;
}
int main()
{
	while(gets(s)!=NULL)
	{
		if(s[0]=='.')
		break;
		len=strlen(s);
		printf("%d\n",get_next(s));
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: