您的位置:首页 > 其它

POJ 题目1787 Charlie's Change(完全背包)

2014-12-04 00:36 323 查看
Charlie's Change

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3149 Accepted: 905
Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task. 

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as
many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the
numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.
Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as
many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".
Sample Input
12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output
Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.

Source

CTU Open 2003

dp[m]表示金额为m是总的金币数目,num[i][m]表示金额为m,第i种的值

ac代码

#include<stdio.h>
#include<string.h>
int dp[10010],num[4][10010];
int main()
{
int m,cnt[4],cost[4]={1,5,10,25};
while(scanf("%d%d%d%d%d",&m,&cnt[0],&cnt[1],&cnt[2],&cnt[3])!=EOF,m||cnt[0]||cnt[1]||cnt[2]||cnt[3])
{
int i,j,k;
memset(dp,-1,sizeof(dp));
memset(num,0,sizeof(num));
dp[0]=0;
for(i=0;i<4;i++)
{
for(j=cost[i];j<=m;j++)
{
if(dp[j-cost[i]]!=-1&&dp[j]<dp[j-cost[i]]+1&&num[i][j-cost[i]]+1<=cnt[i])
{
dp[j]=dp[j-cost[i]]+1;
num[i][j]=num[i][j-cost[i]]+1;
for(k=0;k<i;k++)
num[k][j]=num[k][j-cost[i]];
}
}
}
if(dp[m]==-1)
printf("Charlie cannot buy coffee.\n");
else
printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",num[0][m],num[1][m],num[2][m],num[3][m]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: