您的位置:首页 > 其它

hdu1546 zoj 2750 Idiomatic Phrases Game (dijkstra)

2014-12-03 17:39 316 查看
<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Idiomatic Phrases Game</span>


Time Limit: 2 Seconds
Memory Limit: 65536 KB

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with
the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary
has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and
an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The
input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0xfffffff
using namespace std;

int n;
int minute[1005];
char idiom[1005][100];
int graph[1005][1005];
int vis[1005];
int d[1005];

void dijkstra()
{
    memset(vis,0,sizeof(vis));
    int s=1;
    vis[1]=1;
    int cnt=1;
    int min=INF;
    for(int i=1; i<=n; i++)
        d[i]=graph[s][i];
    for(int i=1; i<=n; i++)
    {
        if(vis[i]==0&&min>d[i])
        {
            min=d[i];
            s=i;
        }
    }
    vis[s]=1;
    cnt++;
    while(cnt<n)
    {
        for(int i=1; i<=n; i++)
        {
            if(vis[i]==0&&d[i]>d[s]+graph[s][i])
                d[i]=d[s]+graph[s][i];
        }
        min=INF;
        for(int i=1; i<=n; i++)
        {
            if(vis[i]==0&&min>d[i])
            {
                min=d[i];
                s=i;
            }
        }
        vis[s]=1;
        cnt++;
    }
}

int main()
{
    int len;
    while(scanf("%d",&n)&&n)
    {
        memset(idiom,0,sizeof(idiom));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    graph[i][j]=0;
                else
                    graph[i][j]=INF;
            }
        for(int i=1; i<=n; i++)
        {
            scanf("%d%s",&minute[i],idiom[i]);
        }
        /*cout<<"debug:"<<endl;
        for(int i=1;i<=n;i++)
        {
            cout<<minute[i]<<" ";
            puts(idiom[i]);
        }*/
        for(int i=1; i<=n; i++)
        {
            len=strlen(idiom[i]);
            for(int j=1; j<=n; j++)
            {
                if(j!=i&&idiom[i][len-4]==idiom[j][0]&&idiom[i][len-3]==idiom[j][1]&&idiom[i][len-2]==idiom[j][2]&&idiom[i][len-1]==idiom[j][3])
                {
                    graph[i][j]=minute[i];
                }
            }
        }
        /*cout<<"debug:"<<endl;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(j==n)
                    cout<<graph[i][j]<<endl;
                else
                    cout<<graph[i][j]<<" ";
            }*/
        dijkstra();
        /*cout<<"debug:"<<endl;
        for(int i=1; i<=n; i++)
            cout<<d[i]<<" ";
        cout<<endl;*/
        if(d
==INF)
            printf("-1\n");
        else
            printf("%d\n",d
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: