您的位置:首页 > 其它

Bellman_Ford变形求最长路+正权回路或spfa——POJ 1860

2014-12-03 14:08 417 查看
对应POJ题目:点击打开链接

Currency Exchange

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 20814Accepted: 7451
Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

Source

题意:有若干种货币,某些币种之间可兑换,给出各种兑换时的汇率r和手续费c,任何兑换都是双向的,但是两个方向的汇率和手续费可能不同,并告知你现在拥有的货币种类s(只拥有一种)及数量v,问是否可以通过货币建兑换最后回到本币种后钱数有所增加。

A->B (s-c)*r

思路:Bellman_Ford求最长路径,判断是否存在正权回路,是则输出YES,或者spfa求最长路径,用个in[i]数组判断点i入队次数是否大于n, 是则输出YES

Bellman_Ford:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=10000+10;
const int INF=1<<30;
using namespace std;
double dis[105];

struct Edge
{
	int u,v;
	double r,c;
}E[MAXN];

bool Bellman_Ford(int s, int n, double v, int size)
{
	for(int i=1; i<=n; i++) dis[i]=0.0;
	dis[s] = v;
	for(int i=1; i<=n-1; i++){
		for(int j=0; j<size; j++){
			if((dis[E[j].u] - E[j].c) * E[j].r > dis[E[j].v])
				dis[E[j].v] = (dis[E[j].u] - E[j].c) * E[j].r;
		}
	}
	for(int i=0; i<size; i++){
		if((dis[E[i].u] - E[i].c) * E[i].r > dis[E[i].v])
			return true;
	}
	return false;
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n,m,s;
	double v;
	int size = 0 ;
	scanf("%d%d%d%lf", &n,&m,&s,&v);
	for(int i=0; i<m; i++){
		int u,v;
		double r,c;
		scanf("%d%d%lf%lf", &u,&v,&r,&c);
		E[size].u = u;
		E[size].v = v;
		E[size].r = r;
		E[size++].c = c;
		scanf("%lf%lf", &r,&c);
		E[size].u = v;
		E[size].v = u;
		E[size].r = r;
		E[size++].c = c;
	}
	bool ok = Bellman_Ford(s,n,v,size);
	if(ok) printf("YES\n");
	else printf("NO\n");
	return 0;
}


spfa:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=10000+10;
const int INF=1<<30;
using namespace std;
double dis[105];
int head[105];
int vis[105];
int in[105];

struct Edge
{
	int v,next;
	double r,c;
}E[MAXN];

bool spfa(int s, int n, double v)
{
	for(int i=1; i<=n; i++) dis[i] = 0.0;
	dis[s] = v;
	queue<int>q;
	q.push(s);
	vis[s] = 1;
	in[s]++;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u] = 0;
		for(int i=head[u]; i!=-1; i=E[i].next){
			int v = E[i].v;
			if((dis[u] - E[i].c) * E[i].r > dis[v]){
				dis[v] = (dis[u] - E[i].c) * E[i].r;
				if(!vis[v]){
					vis[v] = 1;
					in[v]++;
					if(in[v] > n) return true;
					q.push(v);
				}
			}
		}
		if(dis[s] > v) return true;
	}
	return false;
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n,m,s;
	double v;
	int size = 0 ;
	scanf("%d%d%d%lf", &n,&m,&s,&v);
	memset(head, -1, sizeof(head));
	for(int i=0; i<m; i++){
		int u,v;
		double r,c;
		scanf("%d%d%lf%lf", &u,&v,&r,&c);
		E[size].v = v;
		E[size].r = r;
		E[size].c = c;
		E[size].next = head[u];
		head[u] = size++ ;
		scanf("%lf%lf", &r,&c);
		E[size].v = u;
		E[size].r = r;
		E[size].c = c;
		E[size].next = head[v];
		head[v] = size++;
	}
	bool ok = spfa(s,n,v);
	if(ok) printf("YES\n");
	else printf("NO\n");
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: