您的位置:首页 > 大数据 > 人工智能

HDU 5112 —— STL pair 的用法

2014-12-03 13:35 309 查看


A Curious Matt

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 258 Accepted Submission(s): 170



Problem Description

There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please
help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.



Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time.
It’s guaranteed that all ti would be distinct.



Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.



Sample Input

2
3
2 2
1 1
3 4
3
0 3
1 5
2 0




Sample Output

Case #1: 2.00
Case #2: 5.00

HintIn the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.




pair 实质上就类似于结构体,看起来跟map容器有点像,只是map容器会自动排序,而pair与结构体一样不会自动排序。。将两种类型捆绑在一起,第一个成员用first 表示,第二个成员用second表示。还可以直接用make_pair(a,b)将a,b这两种数据捆绑在一起。

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;

int main()
{
    int T, n, c = 1;

    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        pair<double,double> p[10010];
        for(int i=0; i<n; i++)
            scanf("%lf%lf", &p[i].first,&p[i].second);
        sort(p,p+n);
        double maxn = 0.0;
        for(int i=1; i<n; i++)
        {
            maxn = max(maxn,fabs((p[i].second-p[i-1].second)/(p[i].first-p[i-1].first)));
        }
        printf("Case #%d: %.2f\n", c++,maxn);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: