您的位置:首页 > 其它

根据二叉树的前序和中序求解树

2014-12-02 20:25 267 查看
求解方法类似于根据中序和后序求解树

根据前序把中序分为左右子树,然后依次递归。



前序:ABCDEFG

中序:CBDEAFG

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
typedef struct node
{
char data;
struct node *rchild,*lchild;
}BiTNode,*BiTree;
void PreOrder(BiTree T)//前序遍历
{
if(T==NULL)
{
return;
}
printf("%c ",T->data);
PreOrder(T->lchild);
PreOrder(T->rchild);
}
void InOrder(BiTree T)//中序遍历
{
if(T==NULL)
{
return;
}

InOrder(T->lchild);
printf("%c ",T->data);
InOrder(T->rchild);
}
void Creat_Pre_in(char *pre,char *in,int len,BiTree &T)
{
if(len<=0)
{
T=NULL;
return;
}
int k;
for (char *temp=in; temp<in+len; temp++)
{
if(pre[0]==*temp)
{
k=temp-in;
T=(BiTree)malloc(sizeof(BiTNode));
T->data=*temp;
break;
}
}
Creat_Pre_in(pre+1,in,k,T->lchild);  //递归建立左子树
Creat_Pre_in(pre+k+1,in+k+1,len-k-1,T->rchild);   //递归建立右子树
}
int main()
{
BiTree T1,T2;
char in[20],pre[20];
printf("请输入前序结果:");
scanf("%s",pre);
getchar();
printf("请输入中序结果:");
scanf("%s",in);
int len=strlen(in);
printf("由前序和中序求解树:\n");
Creat_Pre_in(pre,in,len,T2);
printf("前序遍历:");
PreOrder(T2);
printf("\n");
printf("中序遍历:");
InOrder(T2);
printf("\n");

//ABCDEFG
//CBDEAFG
//CEDBGFA
return 0;
}


hdu 1710

Problem Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed
or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.



Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume
they are always correspond to a exclusive binary tree.

Output

For each test case print a single line specifying the corresponding postorder sequence.

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6


Sample Output

7 4 2 8 9 5 6 3 1


#include <iostream>
using namespace std;
int pre[1001],in[1001],n;
typedef struct tree
{
int num;
tree *rchild;
tree *lchild;
tree()
{
rchild=lchild=NULL;
}
}tree;
tree *Root;
void Creat_Binary_Tree(int *Pre,int *In,int n,tree *&root)
{

for (int i=0; i<n; i++)
{
if (Pre[0]==In[i])
{
root=new tree();
root->num=Pre[0];
Creat_Binary_Tree(Pre+1, In, i, root->lchild);
Creat_Binary_Tree(Pre+i+1, In+i+1, n-i-1, root->rchild);
}
}
}
void dfs(tree *root)
{
if(root!=NULL)
{
dfs(root->lchild);
dfs(root->rchild);
if (root==Root)
{
printf("%d\n",root->num);
}
else
{
printf("%d ",root->num);
}

}

}
int main()
{

while (scanf("%d",&n)!=EOF)
{
for (int i=0; i<n; i++)
{
scanf("%d",&pre[i]);
}
for (int i=0; i<n; i++)
{
scanf("%d",&in[i]);
}
Creat_Binary_Tree(pre, in, n, Root);
dfs(Root);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: