您的位置:首页 > 其它

POJ 题目 2488 A Knight's Journey(dfs)

2014-12-02 00:46 411 查看
A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31861 Accepted: 10858
Description


Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

ac代码

#include<stdio.h>
#include<string.h>
int v[26][26],x[2*26],y[2*26];
//int dx[4]={0,1,0,-1};
//int dy[4]={1,0,-1,0};
int n,m,w,xx,yy;
void path(int i,int j,int k)
{
switch(k)
{
case 1:
{xx=i-1,yy=j-2;break;}
case 2:
{xx=i+1,yy=j-2;break;}
case 3:
{xx=i-2,yy=j-1;break;}
case 4:
{xx=i+2,yy=j-1;break;}
case 5:
{xx=i-2,yy=j+1;break;}
case 6:
{xx=i+2,yy=j+1;break;}
case 7:
{xx=i-1,yy=j+2;break;}
case 8:
{xx=i+1,yy=j+2;break;}
}
return;
}
void dfs(int i,int j,int c)
{
int k,ii,jj;
if(i<1||i>n)
return;
if(j<1||j>m)
return;
if(v[i][j])
return;
if(w)
return;
v[i][j]=1;
x[c]=i;
y[c]=j;
if(c==n*m)
{
w=1;
return;
}

for(k=1;k<=8;k++)
{
path(i,j,k);
ii=xx;
jj=yy;
dfs(ii,jj,c+1);
}
v[i][j]=0;
}
int main()
{
int t,c=0;
scanf("%d",&t);
while(t--)
{
//int n,m;
int i,j,k;
memset(x,0,sizeof(x));
memset(y,0,sizeof(y));
memset(v,0,sizeof(v));
scanf("%d%d",&n,&m);
w=0;
printf("Scenario #%d:\n",++c);
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
dfs(i,j,1);
if(w)
{
for(k=1;k<=n*m;k++)
printf("%c%d",y[k]+'A'-1,x[k]);
printf("\n");
break;
}
}
if(w)
break;
}
if(w==0)
printf("impossible\n");
if(t)
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: