您的位置:首页 > 其它

poj 3262 Protecting the Flowers(贪心)

2014-12-01 18:04 369 查看
Protecting the Flowers

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 4562Accepted: 1826
Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent
damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100)
flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return).
FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N

Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics
Output

Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input
6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output
86

Hint
FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful
flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
题目大意:牛会吃花,给的数据是运牛需要的时间,和牛每单位时间吃花的数量,求先运哪个才事花损失的最少

思路:这是贪心,开始的时候我用吃的花数除以时间,但是错了,参考大神代码,才知道要时间除以吃的花数,

但是,我把数据都定义为long long 的时候,就会runtime error 下边注释,不是太懂为什么。

2014,12,1

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
int time; int geshu; double ave;
}a[110000];
bool cmp(struct node a,struct node b){
return a.ave<b.ave;
}
int main(){
int n,i,j,sum;//改成long long就会runtime error
long long x;
scanf("%d",&n);
sum=x=0;
for(i=0;i<n;i++){
scanf("%d%d",&a[i].time,&a[i].geshu);
a[i].ave=a[i].time*1.0/a[i].geshu;
sum+=a[i].geshu;
}
sort(a,a+n,cmp);
for(i=0;i<n;i++){
sum-=a[i].geshu;
x+=sum*a[i].time*2;
}
printf("%I64d\n",x);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: