您的位置:首页 > 其它

POJ 1330 Nearest Common Ancestors (LCA)

2014-12-01 14:59 405 查看
Nearest Common Ancestors
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 19435Accepted: 10294
Description
A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:



In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor
of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node
x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common
ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest
common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree,
2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges.
The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.
Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.
Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output
4
3

Source
Taejon 2002

题目链接:http://poj.org/problem?id=1330

题目大意:输入一棵树,输入树上两节点,求他们的最近公共祖先

题目分析:DFS设定各个节点的层级

#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
int const MAX = 1e4 + 5;
int f[MAX], r[MAX], n;
vector <int> v[MAX];

void DFS(int u, int l)
{
    r[u] = l;
    for(vector<int>::iterator it = v[u].begin(); it != v[u].end(); it++)
        DFS(*it, l + 1);
}

int main()
{
    int T, x, y;
    scanf("%d", &T);
    while(T--)
    {
        memset(f, -1, sizeof(f));
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            v[i].clear();
        for(int i = 0; i < n - 1; i++)
        {
            scanf("%d %d", &x, &y);
            x--;
            y--;
            v[x].push_back(y);
            f[y] = x;
        }
        int root;
        for(int i = 0; i < n; i++)
        {
            if(f[i] == -1)
            {
                root = i;
                break;
            }
        }
        DFS(root, 0);
        scanf("%d %d", &x, &y);
        x--;
        y--;
        while(x != y)
        {
            if(r[x] > r[y])
                x = f[x];
            else
                y = f[y];
        }
        printf("%d\n", x + 1);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: