您的位置:首页 > 其它

poj 3249 Test for Job

2014-11-30 21:37 295 查看
题目链接

Test for Job

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 9335Accepted: 2125
Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will
compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit
Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to
other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input
The input file includes several test cases.

The first line of each test case contains 2 integers n and m(1 ≤
n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.

The next n lines each contain a single integer. The ith line describes the net profit of the city
i, Vi (0 ≤ |Vi| ≤ 20000)

The next m lines each contain two integers x, y indicating that there is a road leads from city
x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output
The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)
Sample Input
6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output
7


题意:有向图图且为DAG,每个点有点权,选择一条以入度为0的点为起点,出度为0的点为终点的路径,让路径上的点的点权和最大。

题解:虚拟一个起点向所有入度为0的点建边,虚拟一个终点,所有出度为0的点向它建边。由于图为DAG,用dp[ i ] 表示以点i为起点,到终点的路径的最大点权和。直接记忆化搜索即可。代码如下:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#define nn 110000
#define inff 0x3fffffff
using namespace std;
int n,m;
struct node
{
int en,next;
}E[nn*10];
int p[nn],num;
int val[nn];
int dp[nn];
void init()
{
memset(p,-1,sizeof(p));
num=0;
}
void add(int st,int en)
{
E[num].en=en;
E[num].next=p[st];
p[st]=num++;
}
int rd[nn],cd[nn];
int dfs(int id)
{
if(dp[id]!=-1)
return dp[id];
dp[id]=val[id];
int i,w;
int ix=-inff;
for(i=p[id];i+1;i=E[i].next)
{
w=E[i].en;
ix=max(ix,dfs(w));
}
if(ix==-inff)
ix=0;
return dp[id]+=ix;
}
int main()
{
int i,u,v;
while(scanf("%d%d",&n,&m)!=EOF)
{
init();
val[0]=val[n+1]=0;
for(i=1;i<=n;i++)
{
scanf("%d",&val[i]);
}
memset(rd,0,sizeof(rd));
memset(cd,0,sizeof(cd));
for(i=1;i<=m;i++)
{
scanf("%d%d",&u,&v);
add(u,v);
cd[u]++;
rd[v]++;
}
for(i=1;i<=n;i++)
{
if(rd[i]==0)
{
add(0,i);
}
if(cd[i]==0)
add(i,n+1);
}
memset(dp,-1,sizeof(dp));
printf("%d\n",dfs(0));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: